Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
PHP5 com Postgresql 8.1
30/08/2007, 12:57
Resposta: #1
PHP5 com Postgresql 8.1
Fiz uma instalação do Debian Etch com Apache 2 + PHP5 + Postgresql 8.1, O problema que está dando erro na primeira função do sistema para acessar o banco pg_connect()

Mensagem de erro

Fatal error: Call to undefined function pg_connect() in /var/www/ems/login.php on line 19

Instalei o módulo php5-pgsql e abilitei a leitura da extenção no PHP.ini

extension=plpgsql.so

O poblema éque parece que o php não consegue executar nenhuma função do pg

O banco está rodando bls, ja fiz a criação das tabelas e a manutenção na console e tb por pgadmin
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2007, 16:18
Resposta: #2
 
como vc instalou o php5-pgsql?
por apt-get install php5-pgsql?
se for... tente desabilitar (comentar) a linha extension=plprsql.so do seu php.ini e restarte o seu servidor web...

valeu..

------------------------------------
Paulo Victor Prestes
Gerente de Tecnologia
Checkout Bank
-------------------------------------
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2007, 16:57
Resposta: #3
 
Caro Paulo foi instalado com aptitude php5-pgsql e fui eu quem colocou o carregamento da biblioteca no php.ini, com e sem ele não funciona.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/09/2007, 16:31
Resposta: #4
 
na verdade nao está funcionando de nenhum jeito, o apt ele configura o php para acessar o banco, sem vc alterar nada apenas restartando o servidor..

------------------------------------
Paulo Victor Prestes
Gerente de Tecnologia
Checkout Bank
-------------------------------------
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/08/2008, 13:04
Resposta: #5
 
cara eu tava com esse mesmo problema, instalei o módulo "php5-pgsql" via apt-get...


"pensei" que o apt-get já configuraria o módulo acima, mas no php.ini vem comentado o .so, que é "extension=pgsql.so", só fiz descomentá-lo e pronto...


tente adicionar "extension=pgsql.so" em vez de "extension=plpgsql.so".


abraço!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS