Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Rede entre Debian e Virtual Machine com WinXP
09/08/2007, 12:46
Resposta: #1
Rede entre Debian e Virtual Machine com WinXP
Como criar uma rede entre o meu Debian e uma Máquina virtual com Winxp?

Agradeço desde já!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/08/2007, 00:16
Resposta: #2
 
normalmente as perguntas se deseja acessar a net na maquina virtual, elas aparecem na instalação do programa da máquina virtual.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/08/2007, 09:57
Resposta: #3
 
dmatrix Escreveu:normalmente as perguntas se deseja acessar a net na maquina virtual, elas aparecem na instalação do programa da máquina virtual.

Ta... mas e depois?
Não tem que configurar nada no Debian ou no WinXP (máquina virtual) ?

Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/08/2007, 14:41
Resposta: #4
 
ah sim... não sei como está as nomenclaturas e ips do dev aí no seu ambiente mas exemplificando, vc deve configurar a rede. digite ifconfig para ver as redes criadas.

se no debian:
eth0: 192.168.0.1

então no WinXP Virtual
eth-virtual: 192.168.0.6
gateway: 192.168.0.1
coloque tb os dns do provedor

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/08/2007, 10:33
Resposta: #5
 
dmatrix Escreveu:ah sim... não sei como está as nomenclaturas e ips do dev aí no seu ambiente mas exemplificando, vc deve configurar a rede. digite ifconfig para ver as redes criadas.

se no debian:
eth0: 192.168.0.1

então no WinXP Virtual
eth-virtual: 192.168.0.6
gateway: 192.168.0.1
coloque tb os dns do provedor

Desculpa a ignorancia dmatrix, mas eu não tenho nem idéia onde coloco esses valores. Tanto no win, qnt no debian!
Nunca precisei mexer com redes e não tenho noção alguma...
Poderia me ajudar passo-a-passo?

O comando ifconfig gera a seguinte saída:

Código:
eth0       Encapsulamento do Link: Ethernet  Endereço de HW 00:13:D4:BB:94:F1
          UP BROADCASTMULTICAST  MTU:1500  Métrica:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Endereço de E/S:0xc000 Memória:cfec0000-cfee0000

lo         Encapsulamento do Link: Loopback Local
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACKRUNNING  MTU:16436  Métrica:1
          RX packets:619758 errors:0 dropped:0 overruns:0 frame:0
          TX packets:619758 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:0
          RX bytes:30988092 (29.5 MiB)  TX bytes:30988092 (29.5 MiB)

nas0       Encapsulamento do Link: Ethernet  Endereço de HW 00:15:E9:0F:51:EE
          endereço inet6: fe80::215:e9ff:fe0f:51ee/64 Escopo:Link
          UP BROADCASTRUNNING MULTICAST  MTU:1500  Métrica:1
          RX packets:274641 errors:0 dropped:0 overruns:0 frame:0
          TX packets:287830 errors:306 dropped:0 overruns:306 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:228964956 (218.3 MiB)  TX bytes:118414458 (112.9 MiB)

ppp0       Encapsulamento do Link: Protocolo Ponto-a-Ponto
          inet end.: 201.41.206.15  P-a-P:201.34.149.254  Masc:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Métrica:1
          RX packets:269986 errors:0 dropped:0 overruns:0 frame:0
          TX packets:288103 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:3
          RX bytes:226399006 (215.9 MiB)  TX bytes:109540194 (104.4 MiB)

vmnet1     Encapsulamento do Link: Ethernet  Endereço de HW 00:50:56:C0:00:01
          inet end.: 172.16.185.1  Bcast:172.16.185.255  Masc:255.255.255.0
          endereço inet6: fe80::250:56ff:fec0:1/64 Escopo:Link
          UP BROADCASTRUNNING MULTICAST  MTU:1500  Métrica:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vmnet8     Encapsulamento do Link: Ethernet  Endereço de HW 00:50:56:C0:00:08
          inet end.: 172.16.102.1  Bcast:172.16.102.255  Masc:255.255.255.0
          endereço inet6: fe80::250:56ff:fec0:8/64 Escopo:Link
          UP BROADCASTRUNNING MULTICAST  MTU:1500  Métrica:1
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Obrigado até agora!

Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/08/2007, 12:56
Resposta: #6
 
Vc ta emulando essa máquina como bride? pq se for é só fonfigurar os ips normalmente, se quiser colocar um como server, é só colocar o ip gw e dns na outra máquina e pronto..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/08/2007, 15:45
Resposta: #7
 
brunodisk Escreveu:Vc ta emulando essa máquina como bride? pq se for é só fonfigurar os ips normalmente, se quiser colocar um como server, é só colocar o ip gw e dns na outra máquina e pronto..

É bridge. Vou precisar do samba né?
Já que minha máquina é winxp.

Obrigado!

Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/08/2007, 16:22
Resposta: #8
 
Sim, coloca o samba, e os dois no mesmo grupo de trabalho e pronto, é só alegria... Eu faço isso direto..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/08/2007, 17:17
Resposta: #9
 
brunodisk Escreveu:Sim, coloca o samba, e os dois no mesmo grupo de trabalho e pronto, é só alegria... Eu faço isso direto..

Mas como configuro o samba para isso?
Se não for pedir demais, você pode me ajudar passo-a-passo?

Obrigado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/08/2007, 21:12
Resposta: #10
 
http://www.vivaolinux.com.br/conf/verCo ... codigo=656

pega esse smb.conf e substitui ele pelo original..
para instalar é só dar um apt-get install samba...
depois da um /etc/init.d/samba stop
subistitui o arquivo smb.conf /etc/samba/smb.conf

configura ele do jeito que vc quer, grupo de trabalho, diretório aonde vc quer que ele compartilhe,.... Pronto vc está na rede...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/08/2007, 09:59
Resposta: #11
 
Olá!
Configurei tudo... Adicionei o usuário vmware no meu Linux e no samba, mudei as permissões da pasta compartilhada. No WinXP, coloquei o nome da máquina como vmware, coloquei o nome lxhome no workgroup, adicionei o IP na minha placa de rede, mas mesmo assim uma mensagem de erro persiste:
Código:
Lxhome não está acessível. Talvez você não tenha permissão para usar este recurso da rede. Contate o administrador deste servidor para saber se você tem permissões de acesso.
O caminho de rede não foi encontrado.
Provavelmente esqueci algo ou errei em alguma parte.
Aí vai meu smb.conf:
Código:
#===== Global Settings =====#
[global]

# Nome do domínio da rede ou grupo de trabalho. Você vai substituir a
# palavra <grupo> pelo nome.
workgroup = LXHOME

# Nome do servidor na rede. Substitua <Servidor Linux>
server string = veiga

# Libera acesso para um ip especifico #
hosts allow = 192.168.1.2

# Bloqueia acesso para um ip especifico #
hosts denny =

# Habilita o suporte a senhas criptografadas #
# encrypt passwords = yes

# O arquivo que contém as senhas #
#smb passwd file = /etc/samba/smbpasswd

# Acesso de usuários. Irei usar <share> para acesso público às pastas.
security = share

hosts allow = ALL

# Se seu servidor vai compartilhar impressora, coloque <yes> no lugar do <no>
load printers = no

# Arquivo de log de acesso
log file = /var/log/samba.%m

# Tamanho máximo do log de acesso
max log size = 50

socket options = TCP_NODELAY

# Endereço IP da máquina na qual está sendo configurado o samba
# Substitua xxx.xxx.xxx.xxx pelo seu IP. Ex.: 192.168.1.5
interfaces = 192.168.1.1
domain master = No
dns proxy = no

read only = no

# Para acessar o servidor, pode ser digitado um nome que você colocará abaixo
netbios name = wiltave

# Se os arquivos são somente leitura, coloque <yes>. Se nos arquivos
# qualquer um pode manejar, deixe <no>. Opto por deixar <no>
read only = no
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No


# Especifica o nível do sistema operacional #
os level = 100

# Diz se o servidor samba terá ou não vantagens de ganhar uma eleição local #
preferred master = yes

# Bloqueando gravações
veto files = /*.mp3/*.exe/*.pif/*.bat/*.{*}/

# Ativa o suporte ao WINS
wins suport = yes

# Usuários que tem acesso ao sistema
valid users = vmware

#===== Share Definitions =====#
# Primeiramente você vai colocar o nome da pasta entre colchetes
[share]

# Agora você vai setar o endereço da pasta dentro do servidor
path = /home/wiltave/share
guest ok = yes
browseable = yes
writable = yes


# Se a pasta for pública, deixe <yes>
public = yes
read only = No

Muito obrigado pela ajuda até agora!
Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/08/2007, 19:20
Resposta: #12
 
Na parte de endereço específico, não coloca nada, deixa comentado...
E da permissão total para essa pasta:/home/wiltave/share
chmod 777 /home/wiltave/share
isso deve resolver....
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/08/2007, 08:11
Resposta: #13
 
O mesmo erro continua no Windows... =/
Fiz tudo o que você disse... Permissão total na pasta, comentei a linha mas mesmo assim não funcionou...

Obrigado!
Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/08/2007, 13:24
Resposta: #14
 
Vc ta no windows querendo logar no linux, vc mapea a rede //servidor/home/pasta sua
e não está aceitando?
da uma chmod 777 /home *
e pronto...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/08/2007, 17:25
Resposta: #15
 
brunodisk Escreveu:Vc ta no windows querendo logar no linux, vc mapea a rede //servidor/home/pasta sua
e não está aceitando?
da uma chmod 777 /home *
e pronto...

cuidado com isso!

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS