Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Squid (apanhando ... rsrsrs) [resolvido]
23/09/2010, 09:14
Resposta: #1
Squid (apanhando ... rsrsrs) [resolvido]
Olá,

instalei o Debian 5.06, tudo ok
instalei o dhcp como abaixo:

ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;

subnet 192.168.2.0 netmask 255.255.255.0 {
range 192.168.2.10 192.168.2.200;
option routers 192.168.2.1;
option domain-name-servers 200.204.0.10,200.204.0.138;
option broadcast-address 192.168.2.255;
}

tudo ok, também, as máquinas pegam ip, dns e tudo mais.

compartilhei a internet que recebo da net (ip dinamico) assim :

#!/bin/bash
echo "1" > /proc/sys/net/ipv4/ip_forward

# Limpando as tabelas
iptables -F
iptables -t
nat -F
iptables -t
mangle -F

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

tudo ok, as máquinas navegam na internet

Instalei o Squid 2.7

li vários tutoriais, configurei meu squid.conf assim :

http_port 3128 tranparent
visible_hostname servidor

cache_mem 64 MB
maximum_object_size_in_memory 64 KB
maximum_object_size 512 MB
minimum_object_size 0 KB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /var/spool/squid 2048 16 256
cache_access_log /var/log/squid/access.log
refresh_pattern ^ftp: 15 20% 2280
refresh_pattern ^gopher: 15 0% 2280
refresh_pattern . 15 20% 2280

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 901 # swat
acl Safe_ports port 1025-65535 # portas altas
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

acl palavrasproibidas dstdom_regex "/etc/squid/bloqueadas"
http_access deny palavrasproibidas

acl redelocal src 192.168.1.0/24
http_access allow localhost
http_access allow redelocal

http_access deny all

criei o arquivo bloqueadas e tudo mais, porém parece que não funciona, o site que bloqueei continua abrindo nas maquinas e o arquivo access.log não tem informação nenhuma das paginas navegadas.

outra coisa junto com o compartilhamento da internet coloquei a linha abaixo pra redirecionar a porta 3128

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

poderiam me ajudar com um passo a passo talves, ou me explicar o que fiz de errado

obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/09/2010, 10:13
Resposta: #2
Re: Squid (apanhando ... rsrsrs)
cleberad Escreveu:Olá,

instalei o Debian 5.06, tudo ok
instalei o dhcp como abaixo:

ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;

subnet 192.168.2.0 netmask 255.255.255.0 {
range 192.168.2.10 192.168.2.200;
option routers 192.168.2.1;
option domain-name-servers 200.204.0.10,200.204.0.138;
option broadcast-address 192.168.2.255;
}

tudo ok, também, as máquinas pegam ip, dns e tudo mais.

compartilhei a internet que recebo da net (ip dinamico) assim :

#!/bin/bash
echo "1" > /proc/sys/net/ipv4/ip_forward

# Limpando as tabelas
iptables -F
iptables -t
nat -F
iptables -t
mangle -F

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

tudo ok, as máquinas navegam na internet

Instalei o Squid 2.7

li vários tutoriais, configurei meu squid.conf assim :

http_port 3128 tranparent
visible_hostname servidor

cache_mem 64 MB
maximum_object_size_in_memory 64 KB
maximum_object_size 512 MB
minimum_object_size 0 KB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /var/spool/squid 2048 16 256
cache_access_log /var/log/squid/access.log
refresh_pattern ^ftp: 15 20% 2280
refresh_pattern ^gopher: 15 0% 2280
refresh_pattern . 15 20% 2280

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl Safe_ports port 901 # swat
acl Safe_ports port 1025-65535 # portas altas
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

acl palavrasproibidas dstdom_regex "/etc/squid/bloqueadas"
http_access deny palavrasproibidas

acl redelocal src 192.168.1.0/24
http_access allow localhost
http_access allow redelocal

http_access deny all

criei o arquivo bloqueadas e tudo mais, porém parece que não funciona, o site que bloqueei continua abrindo nas maquinas e o arquivo access.log não tem informação nenhuma das paginas navegadas.

outra coisa junto com o compartilhamento da internet coloquei a linha abaixo pra redirecionar a porta 3128

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

poderiam me ajudar com um passo a passo talves, ou me explicar o que fiz de errado

obrigado


fiz um teste colocando o numero de proxy no Internet explorer (192.68.2.2 porta 3128) e deu certo travou a pagina que solicitei e criou as entradas no access.log, algo errada na NAT será ?????
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/09/2010, 11:07
Resposta: #3
Re: Squid (apanhando ... rsrsrs) [resolvido]
resolvi, usei esse redirecionamento:

iptables -t nat -A PREROUTING -s SUA_REDE_LOCAL/MASCARA -p tcp --dport 80 -j REDIRECT --to-port 3128
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS