Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
instalando gcc no etch
23/07/2007, 01:25
Resposta: #1
instalando gcc no etch
Qual a maneira de instalar o gcc ? via apt-get ou baixando o tarball ?

pesquisando na web li que se recomenda que se rode o seguinte comando :

cat /proc/version

deve-se instalar a versao que aparecer no console... deve ser este o procedimento ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/07/2007, 11:24
Resposta: #2
 
use o comando cat /proc/version para saber a versão do gcc e depois o o comando apt-cache search gcc para localizar a versão...depois mande instalar com apt-get (ou aptitude) install

Quem acredita, sempre alcança!

Regras para uma boa conduta no Fórum
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/07/2007, 14:52
Resposta: #3
 
fiz o procedimento e instalou ok

eu fui testar com um exemplo que peguei na web e qdo eu tento compilar :

gcc readkey.c -o readkey

aparece o erro :

key.c:4:19: error: stdio.h: No such file or directory

Tem que instalar alguma dependencia para o gcc ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/07/2007, 15:44
Resposta: #4
 
acho que faltam alguns passos...no post abaixo tem algumas dicas...dê uma olhada e veja se te ajuda....caso não dê certo, post aí pra gente tentar resolver..

http://www.forumdebian.com.br/topico-22 ... ht=stdio+h

Quem acredita, sempre alcança!

Regras para uma boa conduta no Fórum
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/07/2007, 14:35
Resposta: #5
 
agora funcionou

Seguindo os passos do post q vc mandou eu instalei o build-essentials e depois o linux-headers

Thanks !!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/07/2007, 14:47
Resposta: #6
 
ok...faltavam só os dois pacotes, né?

Quem acredita, sempre alcança!

Regras para uma boa conduta no Fórum
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/07/2007, 15:02
Resposta: #7
 
sim

instalei eles e estao rodando ok

[]s
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS