Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
placa de rede numca e a mesma... (RESOLVIDO)
01/07/2007, 13:58
Resposta: #16
 
bom fiz tudo como você me disse ate a hora de aplicar o comando : make -C /usr/src/linux-headers-2.6.18-4-k7/ SUBDIRS=$PWD modules


depois ele me deu esta mensagem de erro...


debian:/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source# make -C /usr/src/linux-headers-2.6.18-4-k7/ SUBDIRS=$PWD modules make: Entrando no diretório `/usr/src/linux-headers-2.6.18-4-k7'
CC [M] /home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.o
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_start_xmit’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2235: error: ‘struct skb_shared_info’ has no member named ‘tso_size’/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2236: error: ‘struct skb_shared_info’ has no member named ‘tso_size’/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_start_xmit_optimized’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2338: error: ‘struct skb_shared_info’ has no member named ‘tso_size’/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2339: error: ‘struct skb_shared_info’ has no member named ‘tso_size’/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_change_mtu’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2883: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2911: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_set_mac_address’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2947: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:2959: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_do_nic_poll’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:3944: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:3972: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_set_settings’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4270: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4276: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_nway_reset’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4421: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4427: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_set_ringparam’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4525: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4578: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_set_pauseparam’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4614: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:4620: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c: In function ‘nv_self_test’:
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:5043: error: ‘struct net_device’ has no member named ‘xmit_lock’
/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.c:5059: error: ‘struct net_device’ has no member named ‘xmit_lock’
make[1]: ** [/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source/forcedeth.o] Erro 1
make: ** [_module_/home/carlos/Downloads/NV_Linux_DRV_PKG_v1.21/Fedora5/source] Erro 2
make: Saindo do diretório `/usr/src/linux-headers-2.6.18-4-k7'

Think Different...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2007, 18:58
Resposta: #17
 
é não deu certo então pra atualizar o driver, pelo jeito teremos que tentar outra coisa, veja deixando uma linha no arquivo z25_persistent-net.rules sem o campo ATTRS se enganamos o modulo:
# PCI device 0x10de:0x008c (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", NAME="eth0"

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/07/2007, 11:58
Resposta: #18
 
Me desculpe pela demora na resposta mas tava muito sem tempo estes dias... voltei pra agradecer ao amigo dmatrix, foi batata era so fazer isso mesmo que voce disse que funcionou perfeitamente... claro que antes eu desabilitei a placa de rede onboard no setup, e depois no sistema mesmo editei o arquivo interfaces e apaguei todas as entradas das outras placas e deixei somente a eth0 fiz a mesma coisa com o arquivo z25_persistent-net.rules e apaguei tbm o campo ATTRS como vc me disse reiniciei o pc e habilitei a placa de rede no steup e funcionou perfeitamente... sem problemas nenhum ja reiniciei o pc e tudo e a placa continua a mesma... ou seja problema solucionado... obrigado a todos que se propuseram a me ajudar neste problema...

Think Different...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/12/2007, 14:16
Resposta: #19
 
estou com o mesmo problema
mas não encontrei esse arquivo z25 dentro rules.

ls -l rules
-rw-r--r-- 1 root root 132 2007-10-05 13:45 00-init.rules
-rw-r--r-- 1 root root 272 2007-10-05 13:45 05-options.rules
-rw-r--r-- 1 root root 3076 2007-10-05 13:45 20-names.rules
-rw-r--r-- 1 root root 119 2007-10-05 13:45 30-cdrom_id.rules
-rw-r--r-- 1 root root 3258 2007-10-05 13:45 40-permissions.rules
-rw-r--r-- 1 root root 30 2007-09-18 21:24 45-fuse.rules
-rw-r--r-- 1 root root 210 2007-10-12 09:19 45-hplip.rules
-rw-r--r-- 1 root root 60410 2007-10-15 21:32 45-libgphoto2.rules
-rw-r--r-- 1 root root 50851 2007-10-05 12:03 45-libsane.rules
-rw-r--r-- 1 root root 5716 2007-09-15 23:06 50-xserver-xorg-input-wacom.rules
-rw-r--r-- 1 root root 900 2007-10-12 09:19 55-hpmud.rules
lrwxrwxrwx 1 root root 19 2007-11-24 02:24 60-libpisock.rules -> ../libpisock9.rules
-rw-r--r-- 1 root root 649 2007-10-05 13:45 60-symlinks.rules
-rw-r--r-- 1 root root 1365 2007-10-05 13:45 65-persistent-input.rules
-rw-r--r-- 1 root root 4261 2007-10-05 13:45 65-persistent-storage.rules
-rw-r--r-- 1 root root 760 2007-11-24 03:00 70-persistent-cd.rules
-rw-r--r-- 1 root root 15012 2007-12-22 14:41 70-persistent-net.rules
-rw-r--r-- 1 root root 186 2007-10-05 13:45 75-cd-aliases-generator.rules
-rw-r--r-- 1 root root 869 2007-10-05 13:45 75-persistent-net-generator.rules
-rw-r--r-- 1 root root 564 2007-10-05 13:45 80-programs.rules
-rw-r--r-- 1 root root 171 2007-09-03 23:52 85-alsa.rules
-rw-r--r-- 1 root root 1443 2007-05-18 12:57 85-brltty.rules
-rw-r--r-- 1 root root 81 2007-06-14 06:02 85-hdparm.rules
-rw-r--r-- 1 root root 723 2007-06-25 20:56 85-hplj10xx.rules
-rw-r--r-- 1 root root 126 2007-10-03 01:27 85-hwclock.rules
-rw-r--r-- 1 root root 708 2007-09-19 21:14 85-ifupdown.rules
-rw-r--r-- 1 root root 950 2007-03-07 19:00 85-pcmcia.rules
-rw-r--r-- 1 root root 3040 2007-10-05 13:45 90-modprobe.rules
-rw-r--r-- 1 root root 90 2007-10-08 15:50 95-hal.rules
-rw-r--r-- 1 root root 77 2007-10-05 13:45 99-udevmonitor.rules
lrwxrwxrwx 1 root root 15 2007-11-24 02:24 libmtp.rules -> ../libmtp.rules
-rw-r--r-- 1 root root 1224 2007-10-05 13:45 README
lrwxrwxrwx 1 root root 30 2007-12-21 22:07 z55_alsa-firmware-loaders.rules -> ../alsa-firmware-loaders.rules
[email protected]:/etc/udev/rules.d#
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2007, 13:52
Resposta: #20
 
etapombas Escreveu:-rw-r--r-- 1 root root 15012 2007-12-22 14:41 70-persistent-net.rules
[email protected]:/etc/udev/rules.d#
dá uma olhada nesta regra 70 se o conteúdo não seria o esperado.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/12/2007, 10:24
Resposta: #21
 
Brigadao dmatrix, era lá mesmo o problema!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2008, 16:06
Resposta: #22
 
Cara não querendo ser chato, meu problema já foi resolvido
Mas eu queria saber o porque minha placa wireless aparece com o nome wlan0_ren depois que tirei o endereço da eth0 do persistent-net.rules


############################################
# /etc/udev/rules.d/70-persistent-net.rules
############################################

# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# PCI device 0x10de:0x054c (forcedeth)
SUBSYSTEM=="net", DRIVERS=="?*", NAME="eth0"

# PCI device 0x14e4:0x4311 (ndiswrapper)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{type}=="1", NAME="wlan0"

############################################
# /etc/network/interfaces
############################################
auto lo
iface lo inet loopback


auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

auto eth0
iface eth0 inet manual

auto wlan
iface wlan inet manual

############################################
# ifconfig
############################################
eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:00:6C:25:E5:27
endereço inet6: fe80::200:6cff:fe25:e527/64 Escopo:Link
UP BROADCAST MULTICAST MTU:1500 Métrica:1
pacotes RX:21 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:6 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:2135 (2.0 KB) TX bytes:492 (492.0 b)
IRQ:11

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:16436 Métrica:1
pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0_ren Encapsulamento do Link: Ethernet Endereço de HW 00:1A:73:B8:67:FD
inet end.: 192.168.18.106 Bcast:192.168.18.255 Masc:255.255.255.0
endereço inet6: fe80::21a:73ff:feb8:67fd/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:48 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:74 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:5924 (5.7 KB) TX bytes:8959 (8.7 KB)
IRQ:10 Memória:f6000000-f6004000
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2008, 22:40
Resposta: #23
 
tente o seguinte, substitua a linha onde está:
# PCI device 0x14e4:0x4311 (ndiswrapper)
SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{type}=="1", NAME="wlan0"

por essa:
SUBSYSTEM=="net", DRIVERS=="?*", SYSFS{address}=="00:1A:73:B8:67:FD", NAME="wlan0

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/01/2008, 14:30
Resposta: #24
 
Estava com o mesmo problema, resolvi atualizando o kernel para o mais atual e o problema foi resolvido inclusive a questão de alterar o mac a cada reboot

Blog do Felix
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/01/2008, 20:09
Resposta: #25
 
f3l1x Escreveu:Estava com o mesmo problema, resolvi atualizando o kernel para o mais atual e o problema foi resolvido inclusive a questão de alterar o mac a cada reboot

sim isso resolve tb pois o problema é o modulo do driver e na versão mais recente esse problema foi corrigido. Quando atualizamos o kernel atualiza-se os drivers em geral.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS