Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Amsn 0.97 e xmms no etch (RESOLVIDO)
06/06/2007, 17:47
Resposta: #1
Amsn 0.97 e xmms no etch (RESOLVIDO)
olá.
Devido a uma série de incompatibilidades com A64, reinstalei o etch, dessa vez optando por i386.
O que acontece é que, mesmo tendo feito processos de instalação costumeiros, tive problemas com o xmms e o amsn 0.97.
[email protected]:~$ xmms

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",

Gtk-WARNING **: Não encontrei módulo no module_path: "libsmooth.so",
Message: device: hw:0,1


[email protected]:~$ amsn
Error in startup script: extra characters after close-brace
while executing
"set command [list $self {*}$Snit_optionInfo(configure-$option) $option]
"
(procedure "snit::RT.CacheConfigureCommand" line 36)
invoked from within
"snit::RT.CacheConfigureCommand $type $selfns $win $self $option"
(procedure "::snit::RT.method.configurelist" line 7)
invoked from within
"::snit::RT.method.configurelist $type $selfns $win $self $args"
(procedure "::snit::RT.method.configure" line 4)
invoked from within
"$self configure -width $arrow1width"
(procedure "::pixmapscrollbar::Snit_constructor" line 154)
invoked from within
"::pixmapscrollbar::Snit_constructor ::pixmapscrollbar ::pixmapscrollbar::Snit_inst1 .plugins_log.ys .plugins_log.ys -command {.plugins_log.info yview}"
("eval" body line 1)
invoked from within
"eval [linsert $arglist 0 ${type}::Snit_constructor $type $selfns $instance $instance]"
(procedure "RT.ConstructInstance" line 9)
invoked from within
"RT.ConstructInstance $type $selfns $name $args"
(procedure "::snit::RT.widget.typemethod.create" line 53)
invoked from within
"scrollbar $window.ys -command "$window.info yview""
(procedure "::pluginslog::draw" line 12)
invoked from within
"::pluginslog::draw"
invoked from within
"if { $initialize_amsn == 1 } {
::pluginslog::draw
}"
(file "pluginslog.tcl" line 210)
invoked from within
"source pluginslog.tcl"
("uplevel" body line 27)
invoked from within
"uplevel \#0 {

# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
source amsncore.tcl
source audio.tc..."
(procedure "reload_files" line 2)
invoked from within
"reload_files"
(file "/usr/bin/amsn" line 250)

Se alguém ae puder dar uma mão, agradeço pra caramba.
Valeu ae!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/06/2007, 15:06
Resposta: #2
 
para sanar essas mensagens de warning do xmms vc deve instalar o pacote:
# aptitude install gtk2-engines

já o amsn segundo o desenvolvedor ele não sabe por que ocorre isso mas uma solução alternativa e temporária seria
mudar no arquivo em amsn/utils/snit/snit2.tcl onde está escrito:

{*}$Snit_optionInfo(configure-$option) \

para

{expand}$Snit_optionInfo(configure-$option) \

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/06/2007, 21:20
Resposta: #3
 
Fala, dmatrix. Cara, acho que tu és a alma desse fórum, pq da outra vez que tive problemas aqui tu tb foste o único a me ajudar.
Enfim, voltando ao assunto: já tenho gtk2-engines instalado e, infelizmente, a sugestão do amsn não surtiu efeito algum aqui.
Continuo aceitando sugestões.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2007, 00:22
Resposta: #4
 
ok, então liste os arquivo gtk de configuração pessoal que estão no seu home e renomeie eles assim:
$ ls -l .gtkrc*
deve aparecer uns 2 ou 3 arquivos:
-rw------- 1 59 2007-05-12 13:48 .gtk-bookmarks
-rw-r--r-- 1 147 2007-03-25 11:41 .gtkrc-1.2-gnome2
-rw-r--r-- 1 374 2007-03-23 00:50 .gtkrc.mine

$ mv .gtkrc gtkrc
$ mv .gtkrc-1.2-gnome2 gtkrc-1.2-gnome2

isso deve resolver o problema do xmms, veja aí.

só confirmando, o arquivo que editou do amsn estava no caminho:
/usr/share/amsn/utils/snit/snit2.tcl ?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2007, 15:54
Resposta: #5
 
Agora sim! Pelo menos o xmms ta funcionando! Valeu, cara!

Quanto ao amsn, sim, o arquivo que eu editei estava nesse caminho.
A única coisa que mudou fo a mensagem de erro:

extra characters after close-brace
while executing
"set command [list $self {*}$Snit_optionInfo(cget-$option) $option]
"
(procedure "snit::RT.CacheCgetCommand" line 15)
invoked from within
"snit::RT.CacheCgetCommand $type $selfns $win $self $option"
(procedure "::snit::RT.method.cget" line 3)
invoked from within
"login_screen.lang.icon cget -width"
("eval" body line 1)
invoked from within
"eval $path cget -width"
(procedure "::contentmanager::Snit_typemethodwidth" line 4)
invoked from within
"contentmanager width login_screen lang icon"
("eval" body line 1)
invoked from within
"eval contentmanager width $tree"
("foreach" body line 17)
invoked from within
"foreach item $items {
set tree $options(-tree)
lappend tree $item
# If the item is hidden, skip it
if { [string equal [eval conten..."
("horizontal" arm line 3)
invoked from within
"switch $options(-orient) {
"horizontal" {
set itempady 0
foreach item $items {
set tree $options(-tree)
lappend tree $item
#..."
(procedure "::group::Snit_methodsort" line 19)
invoked from within
"login_screen.lang sort r"
("eval" body line 1)
invoked from within
"eval $path sort $level"
(procedure "::contentmanager::Snit_typemethodsort" line 10)
invoked from within
"contentmanager sort login_screen lang -level r"
("eval" body line 1)
invoked from within
"eval contentmanager sort $tree -level r"
("foreach" body line 11)
invoked from within
"foreach item $items {
set tree $options(-tree)
lappend tree $item
# If the item is hidden, skip it
if { [string equal [eval conten..."
("vertical" arm line 3)
invoked from within
"switch $options(-orient) {
"horizontal" {
set itempady 0
foreach item $items {
set tree $options(-tree)
lappend tree $item
#..."
(procedure "::group::Snit_methodsort" line 19)
invoked from within
"login_screen sort r"
("eval" body line 1)
invoked from within
"eval $path sort $level"
(procedure "::contentmanager::Snit_typemethodsort" line 10)
invoked from within
"contentmanager sort login_screen -level r"
(procedure "::loginscreen::Snit_methodSortElements" line 48)
invoked from within
".main.loginscreen SortElements"
("after" script)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2007, 19:18
Resposta: #6
 
certo, mas então existe mais de uma ocorrência do {*}$Snit_optionInfo(configure-$option) neste arquivo?

é que o meu amsn é 96 e não tem essa string, por isso que não sei quantas vezes existe.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2007, 14:04
Resposta: #7
 
Não. Era só uma mesmo.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/06/2007, 18:46
Resposta: #8
 
Resolvi o problema do amsn.
O bug não era do amsn, mas do Tcl/Tk. Essa versão bugada (8.5a5) ainda corre nos SVN.
Em http://www.tcl.tk/software/tcltk/downloadnow85.html já é possível encontrar a versão 8.5a6 onde o problema está sanado. Então basta compilar o tcl com

$ ./configure --prefix=/usr
# make
# make install

e o tk com

$./configure --prefix=/usr --enable-xft
# make
# make install

Fica aí então a solução pra quem tiver os problemas que eu tive.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS