Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
gpg: keyserver timed out
05/06/2007, 13:58
Resposta: #1
gpg: keyserver timed out
Caros colegas, adicionei 2 (dois) repositorios para minha source.list, conforme lista abaixo:

deb http://ftp.br.debian.org/debian/ etch main
deb-src http://ftp.br.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

deb http://mirrors.kernel.org/debian etch main contrib non-free
deb-src http://mirrors.kernel.org/debian etch main contrib non-free

#Esta aqui em baixo adicionei depois
deb http://www.debian-multimedia.org etch main

deb http://debian.beryl-project.org/ etch main
deb-src http://debian.beryl-project.org/ etch main


Salvei o arquivo e depois rodei um aptitude update, no final deu uma mensagem:

W: GPG error: http://www.debian-multimedia.org etch Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível: NO_PUBKEY 07DC563D1F41B907
W: GPG error: http://debian.beryl-project.org etch Release: As assinaturas a seguir não puderam ser verificadas devido a chave pública não estar disponível: NO_PUBKEY 3FF0DB166A7476EA
W: Você terá que executar apt-get update para corrigir esses problemas


Bom navegando na internet verifiquei que tenho que fazer os seguintes comandos:

:/# gpg --keyserver keyserver.cais.rnp.br --recv-keys 1F41B907
gpg: requesting key 1F41B907 from hkp server keyserver.cais.rnp.br
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

tentei outro:
:/# gpg --keyserver hkp://subkeys.pgp.net --recv-keys 1F41B907
gpg: requesting key 1F41B907 from hkp server subkeys.pgp.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Queria saber se alguem pode me ajudar em relação a este erro das 2 (duas) ultimas linhas:
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

???????????????????????????????????
[/b]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/06/2007, 14:48
Resposta: #2
 
Acabei de experimentar o comando:
# gpg --keyserver hkp://subkeys.pgp.net --recv-keys 1F41B907
e funcionou.

Teste com
#ping subkeys.pgp.net

Se não tiver retorno parecido com este:

PING subkeys.pgp.net (213.239.212.133) 56(84) bytes of data.
64 bytes from maluska.de (213.239.212.133): icmp_seq=1 ttl=54 time=285 ms
64 bytes from maluska.de (213.239.212.133): icmp_seq=2 ttl=54 time=258 ms

--- subkeys.pgp.net ping statistics ---
3 packets transmitted, 2 received, 33% packet loss, time 2003ms
rtt min/avg/max/mdev = 258.331/272.083/285.835/13.752 ms

Verifique se está com acesso à rede.
Verifique seus servidores de DNS.
Verifique se tem algum tipo de firewall no caminho.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/06/2007, 16:36
Resposta: #3
Resolvido....
:/# gpg --keyserver hkp://subkeys.pgp.net --keyserver-options honor-http-proxy --recv-keys 6A7476EA
gpg: requesting key 6A7476EA from hkp server subkeys.pgp.net
gpg: key 6A7476EA: public key "Nicholas Thomas (Repository signing key) <[email protected]>" imported
gpg: Total number processed: 1
gpg: imported: 1

:/# gpg --armor --export 6A7476EA | apt-key add -
OK
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS