Fórum Debian

Versão Completa: python-matplotlib (0.98.1-1+lenny1.1) não importa pylab
Você está atualmente visualizando uma versão simplificada do conteúdo. Visualizar a versão completa com formatação.
Páginas: 1 2
Olá,

A mesagem de erro que recebo é essa ao usar import pylab
ImportError: /usr/lib/python2.5/site-packages/matplotlib/nxutils.so: undefined symbol: __gxx_personality_v0
Acho que alguma atualização desconfigurou ela, pois usava ela sem problemas, alguém sabe se esse problema foi corrigido. No google só achei mensagens reportando o bug.
Obrigado.
Boa noite,

Você já tentou atualizar o pacote para ver se resolve o problema?

Até mais...
Foi justamente uma atualização dessa biblioteca que iniciou o erro ao importar. Acho que isso deve ser sanado até uma próxima atualização da mesma, até lá acho que vou regredir para a versão anterior. Obrigado.
Bom dia,

Baixe os pacotes abaixo e efetue a instalação dos mesmos para ver se o problema e corrigido :

http://debian.mirrors.tds.net/debian/po ... -4_all.deb

http://debian.mirrors.tds.net/debian/po ... _amd64.deb

Ah, coloquei amd64 pois e arquitetura que eu uso, no caso de você usar uma diferente, vá até o site e efetue o download conforme sua arquitetura :

http://debian.mirrors.tds.net/debian/po ... b/?C=S;O=A

Espero ter ajudado...
Até mais...
Quase perfeito,

Muito obrigado pelo endereço. Agora está importando sem problemas porém o janela com um gráfico não mais aparece. É o python-gtk que preciso reconfigurar?
Abraço.
Ok,

Se tudo funcionar perfeitamente, comente a configuração realizada para o python-gtk e altere o tópico para resolvido.

Até mais...
Tentei sudo aptitude reinstall python-gtk2 e continua na mesma. Mais alguma sugestão?
Bom dia orahcio,

Aqui em casa eu mesclo um pouco os pacotes do lenny com o sid, claro, desde que os mesmos não afetem o sistema.
O que você pode fazer e ir ao site http://www.debian.org/distrib/packages#search_packages e procurar por python-matplotlib e verificar as dependências que estão relacionadas a versão do sid.

Até mais...
Mesclar a matplotlib do sid no lenny, resolve o problema de importar a pylab só que continua não abrindo as janelas do gtk com os gráficos. Agradeço a ajuda.
Boa tarde,

Faz isso, aqui em casa funcionou...

Remova o pacote python-matplotlib atualmente instalado.
dpkg --purge python-matplotlib

Vá neste link :

http://sourceforge.net/project/showfile ... _id=608758

E baixe o pacotes matplotlib-0.98.2.tar.gz ou o matplotlib-0.98.1.tar.gz (fica a seu critério).

Ai faça :
tar -zxvf matplotlib-xxxx.tar.gz
cd matplotlib-xxxx
sudo python setup.py build
sudo python setup.py install

Agora só falta testar :

from pylab import *
plot([1,2,2,1/)
show()

Espero ter ajudado...
Até mais...
Boa noite orahcio,

A sugestão enviada, funcionou?

Até mais...
Bom dia,

Desculpe a demora em responder mas achei que havia enviado a resposta e devo ter desconectado antes que o processo concluísse. Mas tive problemas com o gcc em uma das máquinas que uso lenny (não passei do setup.py build). Preciso testar com a minha máquina pessoal, assim que o fizer posto a saída.
Obrigado pela ajuda.

Orahcio
Bom dia,

Apenas fiquei curioso em saber, pois aqui em casa, efetuei os procedimentos acima e funcionou perfeitamente.

Até mais...
Muito obrigado Marcelo pela ajuda. Sabia que eles não deixariam o lenny sem esse recurso por muito tempo, acabei de fazer um dist-upgrade e adivinha que bug foi corrigido?
Grande abraço.

Orahcio
Boa noite Orahcio,

Que ótimo que esta tudo rodando perfeitamente, pena que demorou um pouco, mas vá, nem tudo e perfeito(eheheh).
Edite o tópico para resolvido para aumentarmos a nossa base de conhecimento.

Até mais...
Páginas: 1 2
URL de Referência