Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Compartilhar Pastas via Konqueror
11/02/2007, 20:18
Resposta: #1
Compartilhar Pastas via Konqueror
pessoal,

estou usando o debian etch com KDE, já instalei
samba smbfs smbclient kdenetwork-filesharing

e estou tentando compartilhar uma pasta via konqueror, clicando o botão direito do mouse sobre a pasta e compartilhar

mas ao marcar a opção Compartilhado recebo este erro:

Citar:Ocorreu um erro ao tentar compartilhar a pasta '/home/adriano/teste'. Certifique-se de que o script Perl 'fileshareset' está com o suid root habilitado.

já verifiquei este arquivo fileshareset e já está com suid root
Citar:[email protected]:~$ ls -l /usr/bin/fileshareset
-rwsr-sr-x 1 root root 11003 2006-10-01 14:33 /usr/bin/fileshareset
[email protected]:~$

assim como
[email protected]:~$ ls -l /usr/bin/perl
-rwsr-sr-x 2 root root 1061700 2006-12-06 21:30 /usr/bin/perl
[email protected]:~$

já rebootei a máquina e até alterei o smb.conf, deixando-o assim:
Citar: [global]
workgroup = MOURA
server string = Server
printcap name = /etc/printcap
load printers = yes
security = share
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
unix password sync = no
netbios name = Etch
encrypt passwords = no
map to guest = never
password level = 0
null passwords = yes
os level = 0
preferred master = no
domain master = no
wins support = no
dead time = 0

#======================= Share Definitions ===========================

[Servidor]
comment = Diretório Público
available = yes
browseable = yes
path = /media/dados
public = yes
guest only = no
writable = yes
force create mode = 777
force directory mode = 2777
este /media/dados tá tranquilo, mas quanto tento compartilhar via konqueror que vem a encrenca toda.

alguém já passou por isso ?

Adrianoc
O Complexo nada mais é do que um fila extensa de simplicidades
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/02/2007, 15:49
Resposta: #2
 
verifique se possue o pacote perl-suid instalado:
# aptitude install perl-suid

vc que alterou as permissões do perl para suid?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS