Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
msn proxy transparente
18/07/2006, 23:57
Resposta: #1
msn proxy transparente
oi pessoal estou tentando usar proxy transparente mas depois de tudo configurado nao consigo entrar no msn, funciona tudo certinho mas o msn nem sinal, estou usando Debian 3.1 alguem por gentileza saberia me falar o que pode esta acontecendo ja instalei o debian 3.0 e sempre funcionou numa boa agora nesta versao nova nao consigo fazer funcionar mais um detalhe uso conexao speedy home da telefonica agradeço pela atenção.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/07/2006, 00:23
Resposta: #2
 
Olá edgar_omega,

Como estão suas regras no squid? Teria como postar aqui?

Fernando.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/07/2006, 01:00
Resposta: #3
 
Olá fernando, desde ja agradeço pela sua atençao minhas regras estao basicas

#!/bin/sh
/sbin/iptables -F
/sbin/iptables -t nat -F
#pon
echo 1 > /proc/sys/net/ipv4/ip_forward
/sbin/iptables -A INPUT -p tcp -i ppp0 -d 10.0.0.0/8 --dport 137:139 -j DROP
/sbin/iptables -t nat -A POSTROUTING -s 10.0.0.0/8 -o ppp0 -j MASQUERADE
/sbin/iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

bom eu ja consegui acessar o msn, mas tipo uma vez inserindo as regras depois de iniciar mas depois reinicio e tento novamente pronto ai ja nao da mais certo!!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/07/2006, 08:31
Resposta: #4
 
edgar_omega,

Tente assim então. Faça as regras normalmente e veja se tudo está ok.

Depois faça esses comandos:

Código:
cd /root/
iptables-save > regras_iptables

Ok agora abra o arquivo (como root) /etc/init.d/bootmisc.sh e antes da linha : exit 0 que fica no final coloque:

Código:
iptables-restore < /root/regras_iptables

Veja se isso funciona. Qualquer coisa poste aqui.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/07/2006, 11:51
Resposta: #5
 
Fernando, tive exito com os comandos acima mas tive que tirar o iptables -F
iptables -t nat -F pois quando ele conecta carrega algumas regras e nao funciona ok....
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/07/2006, 18:07
Resposta: #6
posta aqui o seu iptables
posta aqui o seu iptables pra gente dar uma olhda por uso o debian sarge pra servidores com o squid e proxi transparente em umas 10 empresas aqui na cidade e todos rolam file,

Faça sua boa ação do dia responda um topico e ajude alguem a se encantar com o Debian
[email protected]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/07/2006, 23:00
Resposta: #7
Re: posta aqui o seu iptables
fpasqueto Escreveu:posta aqui o seu iptables pra gente dar uma olhda por uso o debian sarge pra servidores com o squid e proxi transparente em umas 10 empresas aqui na cidade e todos rolam file,

Amigo as regras ja havia postado acima mas posso repetilas

#!/bin/sh
#/sbin/iptables -F
#/sbin/iptables -t nat -F
#pon
echo 1 > /proc/sys/net/ipv4/ip_forward
/sbin/iptables -A INPUT -p tcp -i ppp0 -d 10.0.0.0/8 --dport 137:139 -j DROP
/sbin/iptables -t nat -A POSTROUTING -s 10.0.0.0/8 -o ppp0 -j MASQUERADE
/sbin/iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/07/2006, 10:13
Resposta: #8
 
modprobe iptable_nat
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

na segunda linha o eth1 e a placa q esta conectada na internet e na quarta linha o eth0 e a placa q esta na rede local isso quando o seu modem esta como router ou seja ele mesmo disca q e o mais recomendado mas se vc esta fazendo uma discagem pppoe com autenticacao ai muda um poco a regrinha mas e so mudar o eth0 pelo pppo

Faça sua boa ação do dia responda um topico e ajude alguem a se encantar com o Debian
[email protected]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/07/2006, 13:30
Resposta: #9
 
fpasqueto Escreveu:modprobe iptable_nat
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

na segunda linha o eth1 e a placa q esta conectada na internet e na quarta linha o eth0 e a placa q esta na rede local isso quando o seu modem esta como router ou seja ele mesmo disca q e o mais recomendado mas se vc esta fazendo uma discagem pppoe com autenticacao ai muda um poco a regrinha mas e so mudar o eth0 pelo pppo

Deculpe mas nao entendi, bom ja funcionou quando o fernando passou aqueles passos para mim fazer, o problema acho que era o arquivo que havia copiado de outra maquina, e tambem porque eu limpava as regras colocadas pelo pppoe, quando ele se conectava, mas estou usando esta configuracao com as seguintes situacoes

ppp0 rede speedy

eth0 rede interna

coloquei esta regras, dessa maneira, porque assim e logado tudo o que as estacoes navegam...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS