Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Nokia X2 como Modem
10/02/2012, 16:31
Resposta: #1
Nokia X2 como Modem
Pessoal boa tarde a todos! Será que alguém consegue me ajudar no seguinte problema:

Utilizo o celular Nokia X2 como modem para acesso a internet via conexão 3G. Com o wvdial, a conexão ocorre normalmente e não tenho problemas, porém ao conectar como NetworkManager, não consigo conexão. Ao tentar habilitar a coneão no NetworkManager clicando em Habilitar banda larga móvel, nada acontece e são logados os seguintes eventos em /var/log/syslog:

Código:
Feb 10 16:27:59 r2d2 modem-manager: (ttyACM0) opening serial device...
Feb 10 16:27:59 r2d2 modem-manager: Modem /org/freedesktop/ModemManager/Modems/2: state changed (disabled -> enabling)
Feb 10 16:27:59 r2d2 modem-manager: Got failure code 100: Unknown error
Feb 10 16:27:59 r2d2 modem-manager: Modem /org/freedesktop/ModemManager/Modems/2: state changed (enabling -> disabled)
Feb 10 16:27:59 r2d2 modem-manager: (ttyACM0) closing serial device...
Feb 10 16:27:59 r2d2 NetworkManager[12174]: <warn> failed to enable/disable modem: (32) Unknown error

A identificação do celular via lsusb é:

Código:
Bus 001 Device 011: ID 0421:0516 Nokia Mobile Phones

Utilizando o celular para armazenamento de arquivos e conectando via wvdial não tenho problemas, somente pelo NetworkManager. Acredito que o modem-manager não esteja conseguindo passar a informação correta para o NetworkManager. Alguém já passou por um caso parecido?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/02/2012, 21:43
Resposta: #2
RE: Nokia X2 como Modem
ver se quando você usa o wvdial ele acho o modem na ttyACM0 ou em outra porta faz muito tempo que tive este problema e era em relação a isto. e por este motivo sempre usa o wvdial

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/02/2012, 11:59
Resposta: #3
RE: Nokia X2 como Modem
Sim, com o wvdial funciona normal. Acredito que seja alguim problema com o modem-manager.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS