Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Instalação do driver de vídeo via patch para GMA3600/PowerVR (Cedarview) no Debian 7
20/09/2013, 12:10
Resposta: #1
Instalação do driver de vídeo via patch para GMA3600/PowerVR (Cedarview) no Debian 7
Olá

a horas venho buscando esse driver, e finalmente encontrei, no seguinte link
https://downloadcenter.intel.com/Detail_...8&lang=eng

porém as instruções de instalação contidas no mesmo são muito confusas para mim que sou usuário iniciante

gostaria que vocês me guiassem no que preciso fazer
aqui o arquivo INSTALL

Citar:Copyright © 2011 Intel Corporation
INTEL CONFIDENTIAL - FOR INTERNAL USE ONLY

See LICENSE for license and legal terms



Since installation methods may vary based on your Linux distribution, these
instructions are minimal and assume you understand how to compile a Linux
kernel.

Read the ReleaseNotes.txt file first for code name definitions and caveats.



!!! Attention package maintainers !!!

Include the applicable license contained in the LICENSE file in all packages
derived from the cedarview-userspace and cedarview-vaapi tarballs. The kernel
source patch is licensed under the GPLv2. The libwsbm upstream project has a
MIT license.



== Kernel ==

* Apply this kernel patch to avoid a known video playback issue:
* kernel-ttm-clear-high.patch

* Apply the kernel driver patch for your desired target:
* For "Ant": cedarview-kernel-<version>_ant.patch
* For "Bee": cedarview-kernel-<version>_bee.patch

* Add the following line to drivers/staging/Kconfig:
source "drivers/staging/cdv/Kconfig"

* Add the following line to drivers/staging/Makefile:
obj-$(CONFIG_DRM_INTEL_CDV) += cdv/

To enable the Cedarview kernel driver component, be sure to set the following
kernel config variables:

CONFIG_HIGHMEM4G=y
# CONFIG_DRM_PSB is not set
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_DRM_INTEL_CDV=y
CONFIG_DRM_CDV_RELEASE=y
# CONFIG_DRM_CDV_DEBUG is not set
# CONFIG_DRM_PVR_PDUMP is not set

* Compile the kernel and install



== Userspace Components ==

* Unpack and install cedarview-libwsbm binary tarball relative to your root
filesystem:
* cedarview-libwsbm-1.1.0.tar
* If you need to build from source (provided in src/), consult the MeeGo
build profile:
* http://build.meego.com/package/files?pac...rail%3Aoss

* Install libva and dependencies from your package manager.
* See ReleaseNotes.txt for supported versions

* Unpack and install the appropriate userspace (Xorg, 2D, 3D) Cedarview drivers
relative to your root filesystem. While the PowerVR driver is a Mesa
replacement for EGL and GL ES, mesa-libGL of the stated version is required for
OpenGL operation. Note that development headers are installed as well.
* For "Ant": cedarview-userspace-<version>_ant.tar.bz2
* For "Bee": cedarview-userspace-<version>_bee.tar.bz2

* Unpack the PVR VA-API driver for Cedartrail-accelerated H.264, MPEG-2, and
VC1 streams:
* For "Ant": cedarview-vaapi-<version>_ant.tar
* For "Bee": cedarview-vaapi-<version>_bee.tar

* Reboot your system into the new kernel. Starting X will initialize the PVR
driver.

Dentro do tar.gz2 que eu baixei do site da intel vem os seguintes arquivos:

LICENSE
INSTALL
ReleaseNotes.txt
README
/bin/
/bin/cedarview-libwsbm-1.1.0.tar
/bin/cedarview-userspace-v1.0.3_bee.tar
/bin/cedarview-vaapi-v1.0.3_bee.tar
/src/
/src/cedarview-kernel-v1.0.3_bee.patch
/src/cedarview-libwsbm-1.1.0.tar
/src/kernel-ttm-clear-high.patch


encontrei o seguinte artigo que parece funcional
http://www.vivaolinux.com.br/artigo/Apli...l?pagina=2

ele diz pra mim testar, usando
Código:
$ bzip2 -dc /usr/src/cdv-gfx-drivers-1.0.3_bee.tar.bz2 | patch -p1 -s --dry-run

eu faço isso, ele aparentemente exibe o código fonte do patch, e ao final pergunta
Código:
File to patch:

É isso o que devo fazer? o que deveria responder aí?
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS