Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
como ligar o ubuntu sem monitor ? [ Resolvido ]
29/12/2009, 16:26
Resposta: #1
como ligar o ubuntu sem monitor ? [ Resolvido ]
Tenho o ubuntu como servidor, o problema é que se eu ligo ele sem monitor ele da uma mensagem de erro pois a resolução esta muito baixa, teria como eu fazer o ubuntu 9 ligar sem monitor ?
E eu preciso da interfaçe gráfica, pois tenho administrar um banco de dados nela, esse erro eu acho que é algum tipo de bug, pois tenho instalado o Ubuntu 7 e outra máquina, isso não ocorre, se eu plugar o monitor na placa de vídeo, Intel On-bord e reiniciar, inicia normalmente o ambiente gráfico, alguém pode me dar uma sugestão?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2009, 12:51
Resposta: #2
Re: como ligar o ubuntu sem monitor ?
não entendi muito bem porque vc descreve que está ligando o servidor sem monitor e depois vc diz que dá uma mensagem? como vc está visualizando essa mensagem se está sem monitor? remoto? depois vc diz que precisa do monitor para administrar o bd então acredito que vc tenha um monitor para 2 servidores é isso? Bom tente renomear o arquivo /etc/X11/xorg.conf para qualquer outra coisa por exemplo xorg.bak.conf e então tente inicializar o sistema, assim saberemos se existe algo configurado no xorg que esteja fazendo isso.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2009, 15:16
Resposta: #3
Re: como ligar o ubuntu sem monitor ?
Se eu ligar o servidor sem o monitor ele da esse problema, da low-grafic etc...
se eu ligar o servidor com o monitor a parte gráfica sobe normalmente.
se eu ligar o servidor com o monitor plugado e depois desplugar ele continua com o gráfico levantado.
vamos lá, renomiei o arquivo xorg.conf ele criou um novo, coloquei tudo no pastbin.

Xorg.0
http://pastebin.com/m3a490b92
Xorg.0.log
http://pastebin.com/m1956ce8
Xorg.failsafe
http://pastebin.com/m4e25c6e7

Peguei os logues que eu coletei, o xorg que ele criou após eu renomear ele para old, depois eu detei o próprio xorg, e reiniciei a máquina, ela subiu normalmente o gráfico, rsss, eu realmente não sei como lidar com esse novo X.
lembrando que esse tipo de acontecimento não é novo, já vi outras pessoas com o mesmo problema e nao resolveram.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2009, 16:04
Resposta: #4
Re: como ligar o ubuntu sem monitor ?
certo, confirmando... o problema ainda ocorre mesmo com o novo xorg? acredito que tem que customizar alguma opção no xorg.conf para desabilitar a autodetecção.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/12/2009, 07:41
Resposta: #5
Re: como ligar o ubuntu sem monitor ?
vc descreveu que em outra maquina com o ubuntu 7 o problema não ocorre e me parece ser o mesmo chipset de video, talvez vc poderia então executar um livecd deste ubuntu 7 neste servidor e verificar se o mesmo inicializa sem problemas e assim desta forma tentar copiar o xorg.conf desta sessão livecd do ubuntu 7 e colocar neste ubuntu 9 verificando desta forma se o problema ainda ocorre.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/01/2010, 08:04
Resposta: #6
Re: como ligar o ubuntu sem monitor ?
Problema resolvido com essa configuração do xorg.conf

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-68
VertRefresh 50-65
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


Coloquei nos dois servidores que estavam com problema, os dois estão funcionando perfeitamente se o monitor agora, obrigado pela atenção.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS