Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problema com Acentos
10/03/2011, 00:42
Resposta: #1
Problema com Acentos
Ola, pessoal. Estou tendo o seguinte problema : nao consigo digitar letras com acentos em muitos aplicativos (opera, emacs, amsn, python idle, ... ) embora ele funcione normalmente em outros (terminal, vim, iceweasel...). O acento simplesmente nao aparece, nao eh a situacao em que ele aparece porem isolado.
Por um momento eu ate tive tudo funcionando normalmente, mas apenas com o root, quando eu entrava no meu usuario voltava a dar esse erro. Depois de um tempo nem na conta de root ficou mais perfeito (acho que eu estava vasculhando no dpkg-reconfigure locales).
Estou com o layout USA International (with dead keys). Meu teclado nao tem cedilha e o til fica no canto superior a esquerda. Alguem sabe o que pode ser?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2011, 01:38
Resposta: #2
Re: Problema com Acentos
O problema provavelmente é quanto ao layout do teclado, que não está definido como ABNT2. Uma solução possível seria editar o xorg.conf e alterar o layout. A discussão mais longa sobre isso que já vi foi nesse tópico aqui:

viewtopic.php?f=7&t=14077

Dá uma olhada, nesse tópico tem várias medidas que você pode fazer pra tentar consertar.

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2011, 15:07
Resposta: #3
Re: Problema com Acentos
Oi, renatov! (opa! mesmo do orkut, conversa duplicada, hehe .. se quiser melhor ficar so por aqui.. eu acho)
Mas entao, meu teclado nao eh abnt2, ele nao tem cedilha e o til fica em cima a esquerda e nao na direita, eh padrao americano e o locales ja esta como en-US. Eu nao tenho o /etc/X11/xorg.conf , isso eh normal? Eu tenho so ele em outra pasta, de exemplo, com tudo comentado. Eu ja tinha dado uma olhada nesse topic, me pareceu que o problema dele era meio diferente, mas vou ver com mais cuidado. (o acento pra ele aparece, mas isolado. Dependendo da configuracao de layout que eu coloco fica assim tambem, mas na configuracao correta ele aparece em alguns aplicativos de modo totalmente correto e em outros nao aparece)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2011, 21:00
Resposta: #4
Re: Problema com Acentos
Ah sim... você sabe qual é o layout do seu teclado exatamente?

Tente gerar um xorg.conf automaticamente:

Código:
# Xorg -configure
# mv /root/xorg.conf.new /etc/X11/xorg.conf

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2011, 21:21
Resposta: #5
Re: Problema com Acentos
Cara, eu acho que funcionou ! Provavelmente eu estava me afobando em mexer nos locales, sem reiniciar o pc. Estava no en_US.UT8, eu coloquei no en_US.ISO-8859 e aparentemente tá tudo bem ! So far, so good, vamo ver .. falta só uma cedillha no terminal, que não entra ... acho que isto será um problema menor, veremos.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS