Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[Resolvido] -Erro nos modulos xorg.conf e instalação Nvidia.
26/04/2009, 00:49
Resposta: #1
[Resolvido] -Erro nos modulos xorg.conf e instalação Nvidia.
Ontem fui fazer um upgrade no sistema para o kernel 2.6.26-2-686. No entanto, deu erro na inicialização do X. Visto também que adquiri uma placa de vídeo Nvidia Geforce, que creio eu, agravou ainda mais o problema em virtude de não ter o driver de instalação.

Segui inúmeros tópicos, no entanto, sem existo. Sem falar que não achei no site da Nvidia o link para download do drive.

Agradeço se alguém está disposto em me ajudar a resolver estes problemas: Configuração do xorg.conf e instalação da placa Nvidia.

Abaixo está postado o meu xorg.conf

Código:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Fri Sep  5 22:23:08 UTC 2008


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Abaixo está postado $lspci

Código:
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 7100 GS (rev a1)

Abaixo o relatório de erro do X:

Código:
X.Org X Server 1.4.2
X Protocol Version 11, Revision 0

(EE) Failed to load module "type1" (module does not exist 0)
(EE) Failed to load module "nvidia" (module does not exist 0)
(EE) No Drivers available.

Obs: Seguindo tutoriais, instalei os pacotes, nvidia-kernel-common e nvidia-xconfig, mas não tive sucesso algum.

Desde já agradeço bastante se algum contribuir e ajudar no meu problema..

Abraços!

Edit: Horas depois dos erro cometidos... lembrei que havia feito um backup do meu xorg.conf e coloquei para funcionar. Estou agora utilizando minha placa onboard com o 2.6.26-1-686. Mas a Nvidia ainda continua desabilitada

Meu xorg.conf.BACKUP

Código:
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "abnt2"
        Option          "XkbLayout"     "br"
        Option          "XkbVariant"    "abnt2"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
EndSection

Section "Device"
        Identifier      "Configured Video Device"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
EndSection

Abraços novamente!

[Imagem: gpwindox1qw6.jpg]
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/04/2009, 20:53
Resposta: #2
Re: Erro nos modulos xorg.conf e instação Nvidia.
Boa noite,

Segue o link para download do driver :

http://www.nvidia.com.br/object/linux_d ... 51_br.html

Para instalar :

1) Sair do X (/etc/init.d/gdm stop)
2) Fazer backup do xorg.conf
3) Baixar os pacotes necessários para compilação de driver. Verificar wiki do fórum na sessão Hardware.
4) Ajustar os links do gcc. Alterar /usr/bin/gcc que aponta para gcc-4.3 para apontar para gcc-4.1
5) Para instalar faça : driver-baixado --x-module-path=/usr/lib/xorg/modules
6) Restaurar o link do gcc.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/04/2009, 20:30
Resposta: #3
Re: Erro nos modulos xorg.conf e instação Nvidia.
Olá Douglas Almeida,

Seguindo a linha de raciocino do amigo vadinhodebian o que acontece é que o driver da nvidia compila o kernel que está instalado, então como voce ínstalou um novo kernel deve reinstalar o driver da nvidia e tambem para que o x-server xorg seja reconfigurado.

Apenas siga novamente o passo-a-passo para instalação do driver da nvidia na Wiki do debian Alegre

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/04/2009, 23:13
Resposta: #4
Re: Erro nos modulos xorg.conf e instação Nvidia.
Muito obrigado pela atenção de todos. Fiz o download e segui o tutorial do wiki.

No entanto, foi acusado que o drive que foi feito o download não corresponde com o minha plataforma.

Citar:Error: this .run file is intended for the Linux-x86_64 plataform, but you appear to bem running on Linux-x86. Aborting instalation.

Só não entendi o por que você disse que era aquele drive vadinhodebian. Alegre Pensei que fosse um destes dois:
Código:
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 7100 GS (rev a1)

A segunda opção eu até achei comentários sobre ele, no entanto, não achei o link pra download. Mas vou ir baixando drivers de lá e ir testando para ver se consigo..

Obrigado a todos.

[Imagem: gpwindox1qw6.jpg]
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/04/2009, 08:25
Resposta: #5
Re: Erro nos modulos xorg.conf e instação Nvidia.
Douglas,

Tenta instalar este driver aqui da página de downloads da nvidia.

Alegre

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/04/2009, 09:38
Resposta: #6
Re: Erro nos modulos xorg.conf e instação Nvidia.
Bom dia,

Ao verificar o readme podemos constatar que sua placa e compatível com o driver NVIDIA-Linux-x86_64-180.51-pkg2.run.
Segue o link do readme : http://us.download.nvidia.com/XFree86/L ... dix-a.html.

Se sua arquitetura for 64bits você tem que baixar o pkg2 se for 32bits tem que ser o pkg1.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/04/2009, 00:13
Resposta: #7
Re: Erro nos modulos xorg.conf e instação Nvidia.
Caro colegas.. informo que deu tudo certo, para detectar o meu driver tive que utilizar o driver NVIDIA-Linux-x86-180.51-pkg1.run

No entanto, em outra máquina idêntica a minha, não estou tento sucesso. Visto que, quando eu coloco o comando m-a prepare, ele simplesmente não reconhece este comando.
Código:
-bash: m-a: command not found

Fico grato a todos e no aguardo de ajuda!

@br4¢0§ :!:

[Imagem: gpwindox1qw6.jpg]
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/04/2009, 00:40
Resposta: #8
Re: Erro nos modulos xorg.conf e instalação Nvidia.
Boa noite,

Você baixou o pacote "module-assistant" na outra máquina?

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/04/2009, 08:04
Resposta: #9
Re: Erro nos modulos xorg.conf e instalação Nvidia.
Olá Douglas Almeida,

Tente baixar novamente.

Código:
# apt-get install module-assistant gcc

Depois prepare as dependencias

Código:
# m-a prepare

Alegre

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/04/2009, 12:28
Resposta: #10
Re: Erro nos modulos xorg.conf e instalação Nvidia.
Bom dia Douglas,

Conseguiu configurar a placa de vídeo para o outro pc, com as dicas do nosso amigo richex?

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/05/2009, 01:04
Resposta: #11
Re: Erro nos modulos xorg.conf e instalação Nvidia.
Caro colegas.. de fato, faltava instalar o pacote module-assistant, além do gcc-4.1.

Fiquei muito satisfeito e novamente agradeço a todos..

@br4¢0§ :!:

[Imagem: gpwindox1qw6.jpg]
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/05/2009, 18:57
Resposta: #12
Re: [Resolvido] -Erro nos modulos xorg.conf e instalação Nvidia.
Que bom que funcionou, ficamos felizes com isto. Alegre

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS