Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[resolvido] Instalação do google-gadgets
24/01/2011, 16:08
Resposta: #1
[resolvido] Instalação do google-gadgets
Na tentativa de instalar o google gadgets estou tendo um problema. A compilação está sendo encerrada devido a um erro que esta logo abaixo. Me parece ser problema no qt,sendo que todas as dependencias estão instaladas. Alguem ja passou por esse problema? Qual a solução?


Código:
make[5]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/gtk/tests'
make[4]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/gtk'
Making all in qt
make[4]: Entrando no diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
make  all-recursive
make[5]: Entrando no diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
Making all in .
make[6]: Entrando no diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
/bin/sh ../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../.. -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtNetwork -D__STDC_CONSTANT_MACROS            -DNDEBUG            -DGGL_MODULE_DIR=\"/usr/local/lib/google-gadgets/modules\"            -DGGL_INCLUDE_DIR=\"/usr/local/include/google-gadgets\"        -DGGL_SYSDEPS_INCLUDE_DIR=\"/usr/local/lib/google-gadgets/include\"            -DGGL_LIBEXEC_DIR=\"/usr/local/lib/google-gadgets\"            -DGGL_RESOURCE_DIR=\"/usr/local/share/google-gadgets\" -DGGL_HOST_LINUX=1 -DHAVE_X11=1 -DMOZILLA_FIVE_HOME=\"/usr/lib/xulrunner-devel-1.9/lib\" -DHAVE_PTHREAD=1  -O2 -Wall -Wconversion -Werror  -MT libggadget_qt-1.0_la-qt_menu.lo -MD -MP -MF .deps/libggadget_qt-1.0_la-qt_menu.Tpo -c -o libggadget_qt-1.0_la-qt_menu.lo `test -f 'qt_menu.cc' || echo './'`qt_menu.cc
g++ -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../.. -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/QtNetwork -D__STDC_CONSTANT_MACROS -DNDEBUG -DGGL_MODULE_DIR=\"/usr/local/lib/google-gadgets/modules\" -DGGL_INCLUDE_DIR=\"/usr/local/include/google-gadgets\" -DGGL_SYSDEPS_INCLUDE_DIR=\"/usr/local/lib/google-gadgets/include\" -DGGL_LIBEXEC_DIR=\"/usr/local/lib/google-gadgets\" -DGGL_RESOURCE_DIR=\"/usr/local/share/google-gadgets\" -DGGL_HOST_LINUX=1 -DHAVE_X11=1 -DMOZILLA_FIVE_HOME=\"/usr/lib/xulrunner-devel-1.9/lib\" -DHAVE_PTHREAD=1 -O2 -Wall -Wconversion -Werror -MT libggadget_qt-1.0_la-qt_menu.lo -MD -MP -MF .deps/libggadget_qt-1.0_la-qt_menu.Tpo -c qt_menu.cc  -fPIC -DPIC -o .libs/libggadget_qt-1.0_la-qt_menu.o
cc1plus: warnings being treated as errors
In file included from /usr/include/qt4/QtCore/qnamespace.h:41,
                 from /usr/include/qt4/QtCore/qobjectdefs.h:41,
                 from /usr/include/qt4/QtGui/qwindowdefs.h:41,
                 from /usr/include/qt4/QtGui/qwidget.h:41,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtCore/qglobal.h: In function 'qint64 qRound64(qreal)':
/usr/include/qt4/QtCore/qglobal.h:977: error: conversion to 'qreal' from 'qint64' may alter its value
In file included from /usr/include/qt4/QtCore/qstring.h:41,
                 from /usr/include/qt4/QtCore/qobject.h:44,
                 from /usr/include/qt4/QtGui/qwidget.h:42,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtCore/qchar.h: In static member function 'static ushort QChar::highSurrogate(uint)':
/usr/include/qt4/QtCore/qchar.h:291: error: conversion to 'ushort' from 'unsigned int' may alter its value
/usr/include/qt4/QtCore/qchar.h: In static member function 'static ushort QChar::lowSurrogate(uint)':
/usr/include/qt4/QtCore/qchar.h:294: error: conversion to 'ushort' from 'unsigned int' may alter its value
/usr/include/qt4/QtCore/qchar.h: In constructor 'QChar::QChar(uchar, uchar)':
/usr/include/qt4/QtCore/qchar.h:365: error: conversion to 'ushort' from 'int' may alter its value
/usr/include/qt4/QtCore/qchar.h: In member function 'void QChar::setCell(uchar)':
/usr/include/qt4/QtCore/qchar.h:373: error: conversion to 'ushort' from 'int' may alter its value
/usr/include/qt4/QtCore/qchar.h: In member function 'void QChar::setRow(uchar)':
/usr/include/qt4/QtCore/qchar.h:375: error: conversion to 'ushort' from 'int' may alter its value
In file included from /usr/include/qt4/QtCore/qstring.h:42,
                 from /usr/include/qt4/QtCore/qobject.h:44,
                 from /usr/include/qt4/QtGui/qwidget.h:42,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtCore/qbytearray.h: In member function 'QByteRef::operator char() const':
/usr/include/qt4/QtCore/qbytearray.h:428: error: conversion to 'char' from 'int' may alter its value
In file included from /usr/include/qt4/QtGui/qbrush.h:46,
                 from /usr/include/qt4/QtGui/qpalette.h:43,
                 from /usr/include/qt4/QtGui/qwidget.h:44,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtGui/qtransform.h: In member function 'QTransform& QTransform::operator*=(qreal)':
/usr/include/qt4/QtGui/qtransform.h:268: error: conversion to 'unsigned char:5' from 'int' may alter its value
/usr/include/qt4/QtGui/qtransform.h: In member function 'QTransform& QTransform::operator+=(qreal)':
/usr/include/qt4/QtGui/qtransform.h:287: error: conversion to 'unsigned char:5' from 'int' may alter its value
/usr/include/qt4/QtGui/qtransform.h: In member function 'QTransform& QTransform::operator-=(qreal)':
/usr/include/qt4/QtGui/qtransform.h:301: error: conversion to 'unsigned char:5' from 'int' may alter its value
In file included from /usr/include/qt4/QtGui/qwidget.h:44,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtGui/qpalette.h: In member function 'void QPalette::resolve(uint)':
/usr/include/qt4/QtGui/qpalette.h:155: error: conversion to 'unsigned int:28' from 'uint' may alter its value
In file included from /usr/include/qt4/QtGui/qwidget.h:48,
                 from /usr/include/qt4/QtGui/qmenu.h:41,
                 from /usr/include/qt4/QtGui/QMenu:1,
                 from qt_menu.h:20,
                 from qt_menu.cc:19:
/usr/include/qt4/QtGui/qsizepolicy.h: In member function 'void QSizePolicy::transpose()':
/usr/include/qt4/QtGui/qsizepolicy.h:209: error: conversion to 'uchar' from 'int' may alter its value
/usr/include/qt4/QtGui/qsizepolicy.h:210: error: conversion to 'uchar' from 'int' may alter its value
make[6]: ** [libggadget_qt-1.0_la-qt_menu.lo] Erro 1
make[6]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
make[5]: ** [all-recursive] Erro 1
make[5]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
make[4]: ** [all] Erro 2
make[4]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget/qt'
make[3]: ** [all-recursive] Erro 1
make[3]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget'
make[2]: ** [all] Erro 2
make[2]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2/ggadget'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretório `/usr/share/google-gadgets-for-linux-0.9.2'
make: ** [all] Erro 2

* leobr84 em treinamento intenso. Nos passos pela Liberdade..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2011, 16:36
Resposta: #2
Re: Instalação do google-gadgets
Isso parece erro com dependências e pra ver isso seria melhor examinar a saída do comando ./configure, mas vai ser bem mais fácil pra você se o pacote for instalado dos repositórios:

Código:
# aptitude install google-gadgets-qt

Se quiser uma versão mais atual que o Squeeze, instale do repositório do Sid que já vai satisfazer todas as dependências pra você.

Contudo, se você fizer questão de compilar o pacote, seja por aprendizado ou qualquer outro motivo, ao menos resolva as dependências pelos repositórios pra você ter menos dor de cabeça:

Código:
# aptitude build-dep google-gadgets-qt

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2011, 17:11
Resposta: #3
Re: Instalação do google-gadgets
Hum.. Boa dica. Mas no caso utilizo o Lenny, então é só adicionar os repositorios do Squeeze e meter bronca?

* leobr84 em treinamento intenso. Nos passos pela Liberdade..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2011, 18:51
Resposta: #4
Re: Instalação do google-gadgets
Ah, você está no Lenny? O pacote do google-gadgets só está disponível nos repositórios a partir do Squeeze e talvez isso esteja relacionado às versões dos pacotes que estão nas dependências. O jeito mais difícil seria dar uma olhada em todas as dependências, uma por uma, e verificar se as versões que você tem no Lenny são atuais o suficiente para conseguir compilar o google-gadgets e checar a saída do ./configure pra ver se tá faltando alguma coisa.

O jeito mais simples é trocar os repositórios para o Squeeze, dar um update, NÃO atualizar o sistema com upgrade ou safe-upgrade, instalar o google-gadgets-qt, colocar os repositórios do Lenny novamente e dar outro update.

Sinceramente acho que não vale a pena compilar o pacote, pois o Squeeze se tornará o próximo estável por volta do dia 5 de fevereiro, em menos de 2 semanas. Em breve você irá partir definitivamente para o Squeeze e, para fazer isso, vai precisar remover todos os pacotes compilados manualmente. Então já instala de uma vez pelos repositórios do Squeeze Sorrisão

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2011, 23:28
Resposta: #5
Re: Instalação do google-gadgets
Pois é, ainda estou utilizando o Lenny pelo fato do Squeeze ainda não ter sido oficialmente lançado. Então inseri o repositorio do Squeeze, meti o apt-get update e pedi para fazer a instalação do google-gadgets-qt. Mas pelo que estou vendo apareceu muitos conflitos de pacotes e a instalação do google-gadgets resultou na atualização de muitos deles. Na tua opnião num seria mais viável fazer logo um upgrade de distro pra Squeeze? Voce tá gostando do sistema? Aqui o Lenny tá rodando perfeitamente, então será que vale a pena eu arriscar essa atualização?
Abaixo a saída do apt-get.
Código:
debian:/media# aptitude install google-gadgets-qt
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Lendo informações estendidas de estado      
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto  
Os pacotes a seguir estão QUEBRADOS:
  gtk2-engines-pixbuf libatk1.0-dev libc6-dev libc6-i686 libcairo2 libcairo2-dev libfontconfig1-dev
  libgcrypt11-dev libglib2.0-dev libgnutls-dev libgpg-error-dev libgtk2.0-dev libjpeg62-dev libkadm55
  libkrb5-dev libnspr4-dev libnss3-dev libpixman-1-dev libqt4-assistant libqt4-designer libqt4-dev
  libqt4-help libqt4-opengl libqt4-qt3support libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test
  libstartup-notification0-dev libtasn1-3-dev libxcb-render-util0-dev libxcb1 libxcb1-dev libxml2-dev
  libxrandr-dev perl qt4-qtconfig
Os NOVOS pacotes a seguir serão instalados:
  cups-driver-gutenprint{a} cups-ppdc{a} fancontrol{a} foomatic-filters-ppds{a} ghostscript-cups{a}
  google-gadgets-common{a} google-gadgets-gst{a} google-gadgets-qt google-gadgets-xul{a} hpijs{a}
  libc-bin{a} libcupscgi1{a} libcupsdriver1{a} libcupsmime1{a} libcupsppdc1{a} libggadget-1.0-0b{a}
  libggadget-qt-1.0-0b{a} libgssapi-krb5-2{a} libgutenprint2{a} libhpmud0{a} libijs-0.35{a}
  libjbig2dec0{a} libk5crypto3{a} libkrb5-3{a} libkrb5support0{a} libltdl7{a} libmozjs2d{a}
  libopenjpeg2{a} libphonon4{a} libpoppler5{a} libpulse-mainloop-glib0{a} libreadline6{a} libsensors4{a}
  libsnmp-base{a} libsnmp15{a} libxcb-atom1{a} libxcb-aux0{a} libxcb-event1{a} lm-sensors{a} min12xxw{a}
  pnm2ppa{a} ttf-freefont{a} xulrunner-1.9.1{a}
Os pacotes a seguir serão REMOVIDOS:
  avahi-utils{u} ghostscript-x{u} gs-common{u} gs-esp{u} libavahi-compat-libdnssd1{u} psfontmgr{u}
Os pacotes a seguir serão atualizados:
  cups cups-client cups-common fontconfig-config foomatic-db foomatic-db-engine foomatic-filters
  ghostscript iceweasel libasound2 libatk1.0-0 libc6 libcups2 libcupsimage2 libfontconfig1 libgcrypt11
  libglib2.0-0 libgnutls26 libgpg-error0 libgs8 libgtk2.0-0 libhunspell-1.2-0 libjpeg62 libkrb53 libmng1
  libncurses5 libnspr4-0d libnss3-1d libpcre3 libperl5.10 libpixman-1-0 libpulse0 libqt4-dbus
  libqt4-network libqt4-script libqt4-webkit libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4
  libsndfile1 libsoup2.4-1 libsqlite3-0 libssl0.9.8 libstartup-notification0 libtasn1-3
  libxcb-render-util0 libxml2 libxrandr2 locales perl-base poppler-utils
54 pacotes atualizados, 43 novos instalados, 6 a serem removidos e 1135 não atualizados.
É preciso obter 78,7MB de arquivos. Depois do desempacotamento, 63,3MB serão usados.
Os pacotes a seguir possuem dependências não satisfeitas:
  libqt4-opengl: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                 Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libqt4-assistant: Depende: libqt4-network (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                    Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libtasn1-3-dev: Depende: libtasn1-3 (= 1.4-1) mas 2.7-1 será instalado.
  libatk1.0-dev: Depende: libatk1.0-0 (= 1.22.0-1) mas 1.30.0-1 será instalado.
  libglib2.0-dev: Depende: libglib2.0-0 (= 2.16.6-3) mas 2.24.2-1 será instalado.
  libgpg-error-dev: Depende: libgpg-error0 (= 1.4-2) mas 1.6-1 será instalado.
  libqt4-test: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  perl: Depende: perl-base (= 5.10.0-19lenny3) mas 5.10.1-17 será instalado.
  libqt4-sql-mysql: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libgcrypt11-dev: Depende: libgcrypt11 (= 1.4.1-1) mas 1.4.5-2 será instalado.
  gtk2-engines-pixbuf: Depende: libgtk2.0-0 (= 2.12.12-1~lenny2) mas 2.20.1-2 será instalado.
  libqt4-qt3support: Depende: libqt4-network (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                     Depende: libqt4-xml (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                     Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                     Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libcairo2-dev: Depende: libcairo2 (= 1.6.4-7) mas 1.8.10-6 será instalado.
  libcairo2: Quebra: xulrunner-1.9 mas 1.9.0.19-7 está instalado.
  libkrb5-dev: Depende: libkrb53 (= 1.6.dfsg.4~beta1-5lenny6) mas 1.8.3+dfsg-4 será instalado.
  libnss3-dev: Depende: libnss3-1d (< 3.12.3.1-0lenny3.1~) mas 3.12.8-1 será instalado.
  libstartup-notification0-dev: Depende: libstartup-notification0 (= 0.9-1) mas 0.10-1 será instalado.
  libfontconfig1-dev: Depende: libfontconfig1 (= 2.6.0-3) mas 2.8.0-2.1 será instalado.
  libqt4-dev: Depende: libqt4-dbus (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqt4-xml (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqt4-network (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqt4-webkit (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqt4-script (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqt4-xmlpatterns (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libc6-i686: Pré-Depende: libc6 (= 2.7-18lenny7) mas 2.11.2-9 será instalado.
  libxcb1: Quebra: libxcb-xlib0 mas 1.1-1.2 está instalado.
  libqt4-help: Depende: libqt4-network (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
               Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
               Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libgnutls-dev: Depende: libgnutls26 (= 2.4.2-6+lenny2) mas 2.8.6-1 será instalado.
  libxcb-render-util0-dev: Depende: libxcb-render-util0 (= 0.2.1+git1-1) mas 0.3.6-1 será instalado.
  libgtk2.0-dev: Depende: libgtk2.0-0 (= 2.12.12-1~lenny2) mas 2.20.1-2 será instalado.
  libjpeg62-dev: Depende: libjpeg62 (= 6b-14) mas 6b1-1 será instalado.
  libnspr4-dev: Depende: libnspr4-0d (<= 4.7.1-5.1~) mas 4.8.6-1 será instalado.
  libxml2-dev: Depende: libxml2 (= 2.6.32.dfsg-5+lenny3) mas 2.7.8.dfsg-2 será instalado.
  libqt4-sql: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libqt4-svg: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
              Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libqt4-designer: Depende: libqt4-script (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                   Depende: libqt4-xml (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                   Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                   Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
  libxrandr-dev: Depende: libxrandr2 (= 2:1.2.3-1) mas 2:1.3.0-3 será instalado.
  libkadm55: Depende: libkrb53 (= 1.6.dfsg.4~beta1-5lenny6) mas 1.8.3+dfsg-4 será instalado.
  libc6-dev: Depende: libc6 (= 2.7-18lenny7) mas 2.11.2-9 será instalado.
  libpixman-1-dev: Depende: libpixman-1-0 (= 0.10.0-2) mas 0.16.4-1 será instalado.
  libxcb1-dev: Depende: libxcb1 (= 1.1-1.2) mas 1.6-1 será instalado.
  qt4-qtconfig: Depende: libqtcore4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
                Depende: libqtgui4 (= 4.4.3-1+lenny1) mas 4:4.6.3-4 será instalado.
aberto: 121; fechado: 110; atrasado: 0; conflito: 15                                                         oAs seguintes ações resolverão estas dependências:

Remover os pacotes a seguir:
epiphany-browser
epiphany-extensions
epiphany-gecko
gnome
libdatrie0
libkadm55
libqt4-dev
libqt4-opengl-dev
libxcb-xlib0
libxcb-xlib0-dev
liferea
python-gnome2-extras
serpentine
xulrunner-1.9
xulrunner-1.9-gnome-support

Instalar os pacotes a seguir:
gcc-4.4-base [4.4.5-8 (testing)]
install-info [4.13a.dfsg.1-6 (testing)]
krb5-multidev [1.8.3+dfsg-4 (testing)]
libc-dev-bin [2.11.2-9 (testing)]
libdatrie1 [0.2.4-1 (testing)]
libgssrpc4 [1.8.3+dfsg-4 (testing)]
libgudev-1.0-0 [164-3 (testing)]
libicu44 [4.4.1-7 (testing)]
libkadm5clnt-mit7 [1.8.3+dfsg-4 (testing)]
libkadm5srv-mit7 [1.8.3+dfsg-4 (testing)]
libkdb5-4 [1.8.3+dfsg-4 (testing)]
libmysqlclient16 [5.1.49-3 (testing)]
liborc-0.4-0 [1:0.4.6-2 (testing)]
libudev0 [164-3 (testing)]
libwebkit-1.0-2 [1.2.6-2 (testing)]
libwebkit-1.0-common [1.2.6-2 (testing)]
lpr [1:2008.05.17 (testing)]
manpages-dev [3.27-1 (testing)]
rarian-compat [0.8.1-5 (testing)]

Manter os pacotes a seguir em suas versões atuais:
hpijs [Não Instalado]
libhpmud0 [Não Instalado]
libperl5.10 [5.10.0-19lenny3 (now)]
libsnmp15 [Não Instalado]
perl-base [5.10.0-19lenny3 (now)]

Atualizar os pacotes a seguir:
binutils [2.18.1~cvs20080103-7 (now) -> 2.20.1-15 (testing)]
gconf2 [2.22.0-1 (now) -> 2.28.1-6 (testing)]
gconf2-common [2.22.0-1 (now) -> 2.28.1-6 (testing)]
gnome-doc-utils [0.12.2-1 (now) -> 0.20.1-1 (testing)]
gstreamer0.10-plugins-base [0.10.19-2 (now) -> 0.10.30-1 (testing)]
gtk2-engines-pixbuf [2.12.12-1~lenny2 (now) -> 2.20.1-2 (testing)]
libatk1.0-dev [1.22.0-1 (now) -> 1.30.0-1 (testing)]
libbonobo2-0 [2.22.0-1 (now) -> 2.24.3-1 (testing)]
libbonobo2-common [2.22.0-1 (now) -> 2.24.3-1 (testing)]
libc6-dev [2.7-18lenny7 (stable, now) -> 2.11.2-9 (testing)]
libc6-i686 [2.7-18lenny7 (stable, now) -> 2.11.2-9 (testing)]
libcairo2-dev [1.6.4-7 (now) -> 1.8.10-6 (testing)]
libdbus-glib-1-2 [0.76-1 (now) -> 0.88-2.1 (testing)]
libenchant1c2a [1.4.2-3.3 (now) -> 1.6.0-1 (testing)]
libfontconfig1-dev [2.6.0-3 (now) -> 2.8.0-2.1 (testing)]
libgconf2-4 [2.22.0-1 (now) -> 2.28.1-6 (testing)]
libgcrypt11-dev [1.4.1-1 (now) -> 1.4.5-2 (testing)]
libglib2.0-dev [2.16.6-3 (now) -> 2.24.2-1 (testing)]
libgnutls-dev [2.4.2-6+lenny2 (stable, now) -> 2.8.6-1 (testing)]
libgpg-error-dev [1.4-2 (now) -> 1.6-1 (testing)]
libgstreamer-plugins-base0.10-0 [0.10.19-2 (now) -> 0.10.30-1 (testing)]
libgstreamer-plugins-base0.10-dev [0.10.19-2 (now) -> 0.10.30-1 (testing)]
libgstreamer0.10-0 [0.10.19-3 (now) -> 0.10.30-1 (testing)]
libgstreamer0.10-dev [0.10.19-3 (now) -> 0.10.30-1 (testing)]
libgtk2.0-dev [2.12.12-1~lenny2 (now) -> 2.20.1-2 (testing)]
libjpeg62-dev [6b-14 (now) -> 6b1-1 (testing)]
libkrb5-dev [1.6.dfsg.4~beta1-5lenny6 (stable, now) -> 1.8.3+dfsg-4 (testing)]
libmozjs-dev [1.9.0.19-7 (stable, now) -> 1.9.1.16-4 (testing)]
libnspr4-dev [4.7.1-5 (stable, now) -> 4.8.6-1 (testing)]
libnss3-dev [3.12.3.1-0lenny3 (stable, now) -> 3.12.8-1 (testing)]
libpango1.0-0 [1.20.5-6 (now) -> 1.28.3-1 (testing)]
libpango1.0-common [1.20.5-6 (now) -> 1.28.3-1 (testing)]
libpango1.0-dev [1.20.5-6 (now) -> 1.28.3-1 (testing)]
libpixman-1-dev [0.10.0-2 (now) -> 0.16.4-1 (testing)]
libqt4-assistant [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-designer [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-help [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-opengl [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-qt3support [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-sql [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-sql-mysql [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-svg [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libqt4-test [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
libstartup-notification0-dev [0.9-1 (now) -> 0.10-1 (testing)]
libstdc++6 [4.3.2-1.1 (now) -> 4.4.5-8 (testing)]
libtasn1-3-dev [1.4-1 (now) -> 2.7-1 (testing)]
libthai-data [0.1.9-4+lenny1 (stable, now) -> 0.1.14-2 (testing)]
libthai0 [0.1.9-4+lenny1 (stable, now) -> 0.1.14-2 (testing)]
libtheora0 [1.0~beta3-1+lenny1 (stable, now) -> 1.1.1+dfsg.1-3 (testing)]
libx11-6 [2:1.1.5-2 (now) -> 2:1.3.3-4 (testing)]
libx11-dev [2:1.1.5-2 (now) -> 2:1.3.3-4 (testing)]
libxcb-render-util0-dev [0.2.1+git1-1 (now) -> 0.3.6-1 (testing)]
libxcb1-dev [1.1-1.2 (now) -> 1.6-1 (testing)]
libxml2-dev [2.6.32.dfsg-5+lenny3 (stable, now) -> 2.7.8.dfsg-2 (testing)]
libxrandr-dev [2:1.2.3-1 (now) -> 2:1.3.0-3 (testing)]
libxslt1.1 [1.1.24-2 (now) -> 1.1.26-6 (testing)]
mysql-common [5.0.51a-24+lenny5 (stable, now) -> 5.1.49-3 (testing)]
python-gtkmozembed [2.19.1-3.1 (now) -> 2.25.3-7 (testing)]
python-support [0.8.4lenny2 (now) -> 1.0.10 (testing)]
qt4-qtconfig [4.4.3-1+lenny1 (stable, now) -> 4:4.6.3-4 (testing)]
scrollkeeper [0.3.14-16 (now) -> 0.8.1-5 (testing)]
texinfo [4.11.dfsg.1-4 (now) -> 4.13a.dfsg.1-6 (testing)]
x11proto-randr-dev [1.2.2-1 (now) -> 1.3.1-1 (testing)]
xulrunner-dev [1.9.0.19-7 (stable, now) -> 1.9.1.16-4 (testing)]
yelp [2.22.1-8+b1 (now) -> 2.30.1+webkit-1 (testing)]

Manter as seguintes dependências não resolvidas:
foomatic-db recomenda hpijs
epiphany-browser-data recomenda epiphany-browser
Pontuação é -2134

Aceitar esta solução? [Y/n/q/?]

* leobr84 em treinamento intenso. Nos passos pela Liberdade..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2011, 00:07
Resposta: #6
Re: Instalação do google-gadgets
Na minha opinião, vale a pena instalar o Squeeze há tempos já... ele está congelado faz um tempão, em menos de 2 semanas irá se tornar estável e, ao menos para uso desktop, está melhor que o Lenny. Por exemplo, o emesene e o VLC não funcionam no Lenny, mas no Squeeze estão funcionando. Outra coisa também que senti, quando eu usava transparência verdadeira no fluxbox com xcompmgr, às vezes o sistema travava. Eu pesquisei em todo lugar e a única solução que teve algum resultado pro pessoal foi atualizar o xorg. Agora, aqui no Squeeze, meu sistema não travou nenhuma vez com o xcompmgr + fluxbox, está perfeito. Sem contar que algumas versões mais recentes de pacotes trazem melhorias e mais funcionalidades. Por exemplo, no transmission do Squeeze dá pra editar a lista de trackers. Outro exemplo, no Squeeze o aptitude e o apt-get (synaptic) usam a mesma tabela de dependências e você pode ficar alternando a utilização dele com o aptitude à vontade, nunca terá problemas. Acabei descobrindo que para desktop, realmente vale a pena usar a versão testing. Ainda mais agora, que falta tão pouco pra ela se tornar oficialmente a próxima estável.

Se você quiser fazer o upgrade, é importante que antes você leia isso aqui e tire suas dúvidas:

http://www.debian.org/releases/testing/ ... ng.pt.html
(dá pra ler a partir da seção 4.3)

Se quiser ficar com o Lenny mais um pouco e instalar apenas o pacote dos repositórios testing, após a instalação dele, arrume seu sources.list pro Lenny novamente e rode isso aqui, pro sistema se livrar dos pacotes obsoletos:

Código:
# aptitude full-upgrade

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2011, 11:14
Resposta: #7
Re: Instalação do google-gadgets
Pode crer, renatov. Então é isso mesmo, vou realizar o dist-upgrade para o Squeeze essa noite já que a banda de internet fica mais "leve" e ai ver no quê que da.

Pelo que estou vendo voce preza por ambiente grafico leve e personalizado. Uma certa vez, quando usava o xfce, usei esse recurso de transparencia mas logo tirei por ele ficar consumindo recurso no processador (cerca de 10%) principalmente quando abria o navegador, e o consumo do processador aumentava mais ainda quando abria sites com flash, mesmo em segundo plano e com o recurso de transparencia ativado ele gerava um consumo indesejavel no processador. Tu tem percebido algo desse tipo no flush + xcompmgr?

vlw
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/01/2011, 12:40
Resposta: #8
Re: Instalação do google-gadgets
Código:
$ top -p 2213
PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
2213 rvernuci  20   0  4212 2172  996 S    0  0.1   0:26.85 xcompmgr

Quando rodei o comando, eu estava com 4 janelas abertas, todas sombreadas e transparentes (o terminal por defaul e as outras 3 por estarem desfocadas) e o xcompmgr praticamente nem se fez perceber. A saída é a mesma com um vídeo do youtube rodando em segundo plano com transparência. Ele é muito bom, não consome praticamente nada, oferece transparência verdadeira, blur, shadow, efeito fade-in/fade-out e outras frescuras, é só configurar direito que o desktop fica bem bonito. Eu também uso uma barra para o conky, tilda para terminal transparente estilo quake e gvolwheel para ícone de volume no tray. Com tudo isso, o boot consome só 200 mb, muito menos do que se eu fizesse um equivalente com gnome + compiz.

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2011, 17:58
Resposta: #9
Re: Instalação do google-gadgets
Então, o tópico ficou abandonado por um tempo. Decidi hoje dar uma update em tudo aqui que tá no meu nome. Fiz a atualização do Debian Lenny para o Squeeze e lá nos repositórios está o google-gadgets facilitando e muito o meu trabalho.

Vlw.

* leobr84 em treinamento intenso. Nos passos pela Liberdade..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS