Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
boot com erro:Modprobe:Fatal.. modules.dep não.. Resolvido
21/05/2008, 12:59
Resposta: #1
boot com erro:Modprobe:Fatal.. modules.dep não.. Resolvido
Estou compilando o meu kernel., mas sempre fica dando erro, dizendo que não consegue levantar o modulo net-pf-1 e dá um erro como dizendo que modules.dep não existe. Tem contornar isso? Compilei já pelo make-kpkg, pelo jeito tradicional (make dep, make bzImage, ....) e nada. Tem como me ajudar?[/b]

Tomará que as máquinas dominem o mundo...Assim seriamos considerados reis.......
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/05/2008, 12:23
Resposta: #2
 
execute o comando:
# depmod -a

e veja se resolve.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/05/2008, 22:02
Resposta: #3
 
ja fiz o comando depmod de tudo quanto foi jeito... nada. Até quando eu pego o .config do kerne que não dá esse erro, e compilo aparece esse erro. tem alguma coisa mais que eu possa fazer

Tomará que as máquinas dominem o mundo...Assim seriamos considerados reis.......
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/05/2008, 21:20
Resposta: #4
 
Ai fiz com make-kpkg e criei linux-source e linux-headers. Depois de instalá-los parou essa mensagem.

Tomará que as máquinas dominem o mundo...Assim seriamos considerados reis.......
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/05/2008, 21:26
Resposta: #5
 
bom parece que vc não criou os link:
~# cd /usr/src
~# rm linux ( Removendo antigo link caso exista )
~# ln -s /usr/src/linux-source-`uname -r | cut -f1 -d-` linux

~# cd /lib/modules/`uname -r`
~# rm build ( Removendo antigo link caso exista )
~# ln -s /usr/src/linux-source-`uname -r | cut -f1 -d-` build

verifique isso.
que versão é esse de kernel ?
tá copiando o .config do kernel antigo?

ahh agora que vi...parece que resolveu o problema.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/05/2008, 18:49
Resposta: #6
 
valeu pela ajuda. O único jeito foi instalar o linux-source e linux-headers que fiz pelo make-kpkg. Mas vou testar depois isso. Valeu pela ajuda!!!!


Abraços,


João

Tomará que as máquinas dominem o mundo...Assim seriamos considerados reis.......
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS