Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problema com Grub
28/07/2007, 11:42
Resposta: #1
Problema com Grub
Bom dia a todos.

To com o seguinte problema em meu servidor debian sarg 3.1, fiz a atualização do apache, php e mysql, ambos do debian etch via apt-get tdo funcionou corretamente mas uma semana depois tive que desligar a máquina e qdo fui ligar novamente ocorre um erro no grub e cai no prompt de comando ex. grub> estive pesquisando no fórum e encontrei artigos idênticos segui a resposta de um dos amigos do f´´orum que foi a seguinte:

grub> find /boot/grub/menu.lst
ou
grub> find /grub/menu.lst (se for uma partição independente para o /boot)
Deve sair algo como (hd1,0)
(se tiver mais de um linux - sistema dual boot - tem que escolher um)
Depois disso digite:
grub> root (hd1,0)
Usando o valor correto da partição, e para finalizar:
grub> setup (hd0)
grub> quit

Sigo esses passo beleza nenhum erro porém qdo reinicio novamente o mesmo erro se puderem me ajudar.

Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/07/2007, 03:11
Resposta: #2
 
no seu caso não é erro no grub e sim que no arquivo /boot/grub/menu.lst está referenciado a partição errada tente identificar qual é a partição e depois tente carregar o kernel o initrd correspondente ao seu kernel, exemplo:
Código:
grub> root (hd0,2)
Filesystem type is ext2fs, partition type 0x83

grub> kernel /boot/vmlinuz-2.6.18-custom
   [Linux-bzImage, setup=0x1e00, size=0x17f54e]

grub> initrd /boot/initrd.img-2.6.18-custom

grub> boot

no meu caso acima o root está nesta partição mas teste aí na sua começando com hd0,0 quando aparecer o tipo 0x83 é essa, depois que entrar no sistema vá até o menu.lst e altere para esse valor nas linhas correspondentes.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS